Issues with Formatting / BBCodes in Editor

Baron von Biffo

Well-known member
Joined
May 16, 2007
Messages
12,308
Recently I've noticed a glitch in the editor. If I select a block of text and apply one of the formatting options the effect is not confined to the selected text but is applied to all subsequent text in the editor.

Editor_glitch_1.png

Editor_glitch_2.png

If I then click the formatting button again to reverse the action, the effect is limited to the selected text.

Editor_glitch_3.png

I've only noticed this behaviour since the recent update, which is not to say that it didn't exist prior to that.
 

Attachments



Tech Support

Administrator
Joined
Mar 1, 2019
Messages
282
Recently I've noticed a glitch in the editor. If I select a block of text and apply one of the formatting options the effect is not confined to the selected text but is applied to all subsequent text in the editor.
Yes, this is a known bug in Xenforo version 2.1.3 and it has already been fixed in the next release, 2.1.4.

However, we don't have a date for that release yet.

In the meantime, the workaround is to click the little green "gears" icon in the editor toolbar to go into "source mode" and then fix the formatting manually.

I will double check to see if a patch has been released in the meantime but I'm not aware of one at this time.
 

Tech Support

Administrator
Joined
Mar 1, 2019
Messages
282
On further researching the issue, I found two things:

1. the issue is actually caused by the Froala editor used in Xenforo rather than by Xenforo itself (the reporter there is one of the main Xenforo coders):


2. The issue seems specific to Firefox and can be resolved by switching to Chrome, Safari, or the new Chrome-based Edge. I suspect that is not a real option for most Firefox users.

3. The next release of Xenforo is expected in August and is expected to include a workaround for the Froala problem until Froala fixes their editor.
 

StarryPlough01

Well-known member
Joined
Nov 13, 2010
Messages
14,642
Chrome is owned by Google (say no more).

For Baron Von Biffo - here's a simple fix:


I did find a way around the bug where I underscore everything (or bold). I then highlight the text that doesn't need any emphasis and click the U button to delete the redundant underlining.
Edited to quote the workaround in this post.
 
Last edited by a moderator:


New Threads

Popular Threads

Most Replies

Top